ITF20218 Datakommunikasjon - høsten 2018

Lab 5 i datakommunikasjon.
Seneste frist for skriftlig rapport: Torsdag 18 Oktober.

Grunnleggende konfigurering av rutere

prev next

Denne lab utføres på din egen PC, vha Cisco Packet Tracer Du må da laste ned Packet Tracer til din PC. Før du får tilgang må du også registrere deg, med det er gratis.

Generellt om oppgavene i del 1 og del 2
Konfigurasjonen av utstyret gjøres i Cisco IOS, i simuleringsprogrammet Packet Tracer. Dette grensesnittet er sannsynligvis nytt for de fleste av dere og kan være forvirrende i starten. Det ligger en liste med tips under oppgaven som hjelper dere å komme i gang. Dere finner også informasjon på internett. Eksempelvis: http://danscourses.com/cisco-ios-and-cli/

Læringsmål:

Målet med oppgaven er at dere skal:

En viktig ting å gjøre dere oppmerksom på er at i det virkelige liv vil man gjerne konfigurere slikt nettverksutstyr vha. SSH eller via en RS232-port plassert på baksiden av utstyret. Dette vil dere få prøve senere i kurset.

Besvarelse leveres i form av en kort skriftlig rapport, samt en packet tracer fil for hver del. Rapporten skal inneholde fremgangsmåte, besvarelse på spørsmål i oppgaven samt en konklusjon der dere tar opp problemer dere hadde under oppgaveløsningen. Rapporten skal inneholde besvarelse på alle delene dersom labben er delt opp.

Del 1:

Forberedelse:

Se for dere at dere arbeider i IT avdelingen til et nystartet firma. Firmaet har to avdelinger, Produksjon og salg. Dere må planlegge hvordan dette skal adresseres.
Dere har fått tildelt adresseområdet 10.0.5.100/24 av sjefen, og dette må subnettes slik at dere får riktig antall subnets i henhold til hva dere trenger. Planlegg i detalj hvilke IP-adresser hvert enkelt interface og enhet skal ha før dere setter i gang med oppsett og konfigurasjon av nettverket, dersom dere lager dere en tabell over dette vil det være enklere å holde oversikt. Det vil ikke bli benyttet DHCP i denne lab, derfor må alt adresseres statisk. Husk at hvert VLAN skal ha sitt eget subnet.

Forslag til tabell over nettverket:

Nett1/ProduksjonNett2/Salg
Nettmaske: Nettmaske:
Nettnummer: Nettnummer:
Broadcast: Broadcast:
Første host: Første host:
Siste host: Siste host:
Oppgave:

I denne oppgaven skal dere sette opp kommunikasjon mellom to PCer gjennom en Cisco switch. Dere blir også kjent med VLAN og får se hvordan dette settes opp og benyttes i "praksis".

  1. Kobl opp nettverket slik det er angitt i figuren:

  2. Konfigurer PC1 og PC2 med IP adresser fra "Salg". Bruk subnettet dere har fra forberedelsene.
  3. Ping PC2 fra PC1 og omvendt for å se at det fungerer.
  4. Sett opp Switchen "Salg" med følgende konfigurasjon:
    1. Hostname "Salg"
    2. Lag et nytt VLAN. ID 10 og navn "Produksjon"
    3. Sett opp interfaces mot PC1 og PC2 som access ports med VLAN 10.
  5. Ping PC2 fra PC1 og omvendt for å se at det fungerer.
  6. Sett opp Switchen "Salg" med følgende konfigurasjon:
    1. Lag et nytt VLAN. ID 20 og navn "Salg"
    2. Sett opp interface fa0/3 som access port med tilgang til VLAN 20.
    3. Koble PC2 til interface fa0/3.

  7. Kan PC1 pinge PC2 nå? Begrunn svaret.
  8. Sett opp PC1 med en IP fra "Produksjon" subnettet.
  9. Kan PC1 pinge PC2 nå? Begrunn svaret.

Når du har 100% på aktiviteten kan denne lagres og leveres sammen med labrapport. Rapporten skal inneholde beskrivelse av det du har gjort, svar på spørsmål fra oppgaven samt en utskrift av oppsettet til eventuelle routere og switcher i oppgaven.

Tips:
Noen ting som er verdt å merke seg:

For å teste nettverket kan vi bruke ping-kommandoen på enhetene. Husk at du kan åpne command prompt på PCene fra "Desktop" tabben.
Eksempel:
C:\> ping <ip addresse PC1> (seg selv)
C:\> ping <ip addresse PC2> (PC2)

For å verifisere VLAN, bruk kommandoen:

Switch# show vlan

For å verifisere interface status, bruk kommandoen:

Switch# show interface status

For å verifisere VLAN, bruk kommandoen:

Switch# show running-config eller sh run

Nyttige kommandoer i Cisco IOS:

Hvor Kommando Forkortet Beskrivelse
hostname> enable en Gå inn i privileged EXEC mode.
hostname# configure terminal conf t Gå inn i Global configuration mode.
hostname(config)# hostname  Sett hostname på enheten.
hostname(config)# interface gigabitEthernet 0/0 int g0/0 Sett aktivt interface for konfigurasjon.
hostname(config-if)#switchport access vlan 10 sw a v 10 Knytter interface til vlan 10.
hostname(config)# vlan id   Setter opp nytt vlan, evt går inn på eksisterende.
hostname(config-vlan)# name vlan_name  Setter navn på gjeldende vlan
hostname# show vlan sh vlan Viser VLAN-oppsettet.
hostname# show interface status sh int st Viser status (ink. VLAN) på alle interfaces.
hostname# show running-config sh run Viser running-config (Gjeldende oppsett)
  exit  Går et hakk tilbake i oppsettet.
  end   Går ut av config mode.

 
Eksempel:

Switch# configure terminal
Switch(config)# hostname switch1 ; gi navn til switch eller router
Switch(config)# interface gigabitEthernet 0/1
Switch(config-if)# switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10 ; dette betyr at VLAN 10 ikke eksisterer fra før, og den vil bli laget nå
Switch(config-if)# exit
Switch(config)# vlan 10
Switch(config-vlan)# name Salg
Switch(config-vlan)# exit
Switch(config)#

Del 2:

Linkene viser hvordan trunk kan konfigureres:

VLANs and Trunks for Beginners - Part 1
VLANs and Trunks for Beginners - Part 3
VLANs and Trunks for Beginners - Part 4
Oppgave:

I denne oppgaven skal dere lære hvordan dere setter opp porter som trunk. Dere skal også se hvordan dere benytter en router for å styre kommunikasjon på et nettverk.

  1. Kobl opp nettverket slik det er angitt i figur 1:

  2. Sett opp følgende på switchene:
    1. Hostname. Henholdsvis "Salg" og "Produksjon"
    2. VLAN. ID 10 - Produksjon og ID 20 - Salg.
    3. Trunk på interfaces mellom switcher
    4. Accessport på interfaces mellom switcher og PCer.
  3. Konfigurer PCer med IP tilhørende korrekt subnet.
  4. Kan PC1 pinge PC2? Begrunn svaret.
  5. Koble opp nettverket slik det er angitt i figur 2: Legg merke til at når vi setter opp nettverket på denne måten er det behov for et fysisk interface til hvert VLAN.

  6. Sett opp nødvendig konfigurasjon på switch "Salg". To interfaces. Ett til hvert LAN.
  7. Sett opp nødvendig konfigurasjon på routeren.
    1. Hostname skal være "R1".
    2. g0/0, dette skal ha IP adresse tilhørende "Produksjon".
    3. g0/1, dette skal ha IP adresse tilhørende "Salg".
  8. Kan PC1 pinge PC2? Begrunn svaret.
  9. Sett opp Gateway på PC1 og PC2.
  10. Kan PC1 pinge PC2? Begrunn svaret.
  11. Koble opp nettverket slik det er angitt i figur 3: Legg merke til at her benytter vi kun 1 kabel, uavhengig av antallet VLANs. Dette er mye mer praktisk sammenlignet med det forrige oppsettet der det var behov for 1 kabel per VLAN. Legg også merke til at vi skifter port på routeren til g0/1.

  12. Konfigurer switch og router.
    1. Sett opp trunk på switch.
    2. Sett opp subinterfaces på routeren, husk no shut på det fysiske interfacet. Se tips for kommandoer
  13. Kan PC1 pinge PC2? Begrunn svaret.
    Dersom du har problemer på dette steget kan du forsøke å skrive arp -d i command prompt på hver PC.

Når du har 100% på aktiviteten kan denne lagres og leveres sammen med labrapport. Rapporten skal inneholde beskrivelse av det du har gjort, svar på spørsmål fra oppgaven samt en utskrift av oppsettet til eventuelle routere og switcher i oppgaven.

Tips:
Nyttige kommandoer i Cisco IOS:

Hvor Kommando Forkortet Beskrivelse
hostname> enable en Gå inn i privileged EXEC mode.
hostname# configure terminal conf t Gå inn i Global configuration mode.
hostname(config)# hostname  Sett hostname på enheten.
hostname(config)# interface gigabitEthernet 0/0 int g0/0 Sett aktivt interface for konfigurasjon.
hostname(config)# default interface gigabitEthernet 0/0 def int g0/0 Resetter interface til opprinnelig oppsett.
hostname(config)# vlan 10   Lager et nytt VLAN med ID 10. (switch)
hostname(config-vlan)# name Produksjon  Setter navnet "Produksjon" på gjeldende VLAN. (switch)
hostname(config-if)# switchport access vlan 10 sw a v 10 Knytter interface til vlan 10.
hostname(config-if)# switchport mode trunk  Setter interface til å være trunk.
hostname# show vlan sh vlan Viser VLAN-oppsettet.
hostname# show interface status sh int st Viser status (ink. VLAN) på alle interfaces. Kun switcher.
hostname# show running-config sh run Viser running-config (Gjeldende oppsett).
hostname(config-if)# ip address 10.10.10.1 255.0.0.0   Setter IP på et interface. (Kun behov på router her).
hostname(config-if)# no shutdown no shut Aktiverer interfacet.
  exit  Går et hakk tilbake i oppsettet.
  end   Går ut av config mode.

Eksempel på oppsett av subinterface:

R1> enable
R1# configure terminal
R1(config)# default interface g0/0
R1(config)# interface g0/0.10
R1(config-subif)# encapsulation dot1Q 20
R1(config-subif)# ip address 10.10.10.1 255.0.0.0
R1(config-subif)# no shutdown

Eksempel på oppsett av interface:

R1> enable
R1# configure terminal
R1(config)# interface GigabitEthernet 0/1
R1(config-if)# ip address 10.10.10.1 255.0.0.0
R1(config-if)# no shutdown

 


Tilbake til Fag ITF20218 - oppgaveoversikt
Tilbake til Fag ITF20218 - timeoversikt
Tilbake til Fag ITF20218 - hovedside

Erling.P.Strand@hiof.no
Patrick Winnem